Информатика, вопрос задал Vladislav12304 , 8 лет назад

Напишите программу, решающую следующую задачу. С клавиатуры вводятся количество пятерок, количество четверок и количество троек, полученных учащимся в четверти. На экран необходимо вывести проценты пятерок, четверок и троек от общего количества оценок, полученных учащимся в четверти. Очевидно, что сумма процентов пятерок, четверок и троек должна быть равна 100 процентам. При выводе процентов используйте форматированный вывод, задав ширину выводимого результата 6, а количество знаков после десятичной точки — 1.

Ответы на вопрос

Ответил petyaGavrikov
0
var k5,k4,k3,s:integer;
begin
readln(k5,k4,k3);
s:=k5+k4+k3;
writeln('Пятёрок - ',k5/s*100:6:1,' %');
writeln('Четвёрок - ',k4/s*100:6:1,' %');
writeln('Троек - ',k3/s*100:6:1,' %');
end.

Пример:
5 3 2
Пятёрок - 50.0 %
Четвёрок - 30.0 %
Троек - 20.0 %
Новые вопросы