Информатика, вопрос задал ivancherry0412 , 1 год назад

Напишите программу, разбивающую любое трехзначное число на разряды, и вычисляющую сумму цифр в этом трехзначном числе. Для того, чтобы раз- бить число на разряды, используйте операции div и mod.

Ответы на вопрос

Ответил Kirpi4ik1
1

Ответ:

rogram SplitAndSumDigits;

var

 number, digit1, digit2, digit3, sum: integer;

begin

 // Ввод трехзначного числа

 write('Введите трехзначное число: ');

 readln(number);

 // Разбиваем число на разряды

 digit3 := number mod 10;

 number := number div 10;

 digit2 := number mod 10;

 number := number div 10;

 digit1 := number;

 // Вычисляем сумму цифр

 sum := digit1 + digit2 + digit3;

 // Выводим результат

 writeln('Первая цифра: ', digit1);

 writeln('Вторая цифра: ', digit2);

 writeln('Третья цифра: ', digit3);

 writeln('Сумма цифр: ', sum);

 readln;

end.

Объяснение:

Эта программа просит пользователя ввести трехзначное число, затем разбивает его на отдельные цифры с использованием операций div и mod и, наконец, вычисляет сумму цифр.

Новые вопросы