Информатика, вопрос задал BadNotBad , 7 лет назад

Напишите программу, проверит является ли билетик счастливым. Номер билета семизничный
Счастливым считается такой билет сумма цифр которого на четных позициях равна сумме цифр на нечетных
позициях. Например, 1234167
python срочно пожалуйста

Ответы на вопрос

Ответил stglupa
1

s = str(input())

sum1 = 0

sum2 = 0

for i in range(0, 7, 2):

   sum1 += int(s[i])

for i in range(1, 7, 2):

   sum2 += int(s[i])

if sum1 == sum2:

   print("YES")

else:

   print("NO")

Новые вопросы