Напишите программу, при помощи которой можно подсчитать расходы на доставку мебели. Исходные данные для расчета – номер этажа и информация о наличии и типе лифта (грузовой или обычный). C++
Ответы на вопрос
Ответил dydx
0
Надеюсь без ошибок. Цену за отдельные аспекты назначте сами:
#include stdlib.h
#include <iostream>
using namespace std;
int main() {
setlocale(LC_ALL, "Russian");
int floor;
char lift, type0;
double price_floor;
double price_elevator;
double price_type;
double total_price;
bool elevator;
cout << "Введите номер этажа: ";
cin >> floor;
if (floor == 1 || floor <= 3) price_floor=1;
if (floor <= 6 && floor > 3) price_floor=2;
if (floor <= 9 && floor > 6) price_floor=3;
else if price_floor=4;
cout << "Имеется ли в вашем помещении лифт? "; //Ответ + или -
cin >> lift;
switch (lift) {
case '+':
price_elevator=1;
elevator=true;
break;
case '-':
price_elevator=2;
break;
}
if (elevator) {
cout << "Грузоподъемный? ";
cin >> type0;
switch (type0) {
case '+':
price_type=1
break;
case '-':
price_type=2;
break;
}
}
else if cout <<"n";
cout <<"n";
total_price=price_elevator + price_floor + price_type;
cout << "Конечная цена: " << total_price <<endl;
system ("pause");
return 0;
}
#include stdlib.h
#include <iostream>
using namespace std;
int main() {
setlocale(LC_ALL, "Russian");
int floor;
char lift, type0;
double price_floor;
double price_elevator;
double price_type;
double total_price;
bool elevator;
cout << "Введите номер этажа: ";
cin >> floor;
if (floor == 1 || floor <= 3) price_floor=1;
if (floor <= 6 && floor > 3) price_floor=2;
if (floor <= 9 && floor > 6) price_floor=3;
else if price_floor=4;
cout << "Имеется ли в вашем помещении лифт? "; //Ответ + или -
cin >> lift;
switch (lift) {
case '+':
price_elevator=1;
elevator=true;
break;
case '-':
price_elevator=2;
break;
}
if (elevator) {
cout << "Грузоподъемный? ";
cin >> type0;
switch (type0) {
case '+':
price_type=1
break;
case '-':
price_type=2;
break;
}
}
else if cout <<"n";
cout <<"n";
total_price=price_elevator + price_floor + price_type;
cout << "Конечная цена: " << total_price <<endl;
system ("pause");
return 0;
}
Новые вопросы
Литература,
2 года назад
Химия,
2 года назад
Химия,
8 лет назад
Химия,
8 лет назад
Математика,
9 лет назад