Напишите программу, пожалуйста, на Pascal.
Даны координаты нижнего левого угла квадрата на плоскости X и Y, и его площадь S. Требуется проверить, попала ли точка, координаты которой задаёт пользователь, внутрь или на границу квадрата.
Ответы на вопрос
Ответил karimPhoenix
0
uses crt;
var x,y,s,z1,z2,c1,c2:real;
begin
write('s=');
read(s);
write('x=');
read(x);
write('y=');
read(y);
s:=sqrt(s);
write('vvedite 1 koordinaty');
read(c1);
write('vvedite 2 koordinaty');
read(c2);
z1:=s+x;
z2:=s+y;
if (c1<=z1)and(c2<=z2)and(c1>=x)and(c2>=y) then
write('to4ka popala')
else
write('to4ka ne popala.');
read;
end.
где с1-первая координата, с2-вторая, z1 и z2-вспомогательные точки))) ну там разберешься)))
Новые вопросы