Напишите программу: Посчитать количество четных цифр в числе, введенном с клавиатуры. pascal
Ответы на вопрос
Ответил Аноним
0
PascalABC.NET 3.3.5, сборка 1644 от 23.03.2018
Внимание! Если программа не работает, обновите версию!
begin
var (n,k):=(Abs(ReadInteger('n=')),0);
if n=0 then k:=1
else
while n>0 do begin
if (n mod 10).IsEven then k+=1;
n:=n div 10
end;
Writeln('Четных цифр: ',k)
end.
Пример
n= -623451
Четных цифр: 3
Внимание! Если программа не работает, обновите версию!
begin
var (n,k):=(Abs(ReadInteger('n=')),0);
if n=0 then k:=1
else
while n>0 do begin
if (n mod 10).IsEven then k+=1;
n:=n div 10
end;
Writeln('Четных цифр: ',k)
end.
Пример
n= -623451
Четных цифр: 3
Ответил AndreyNikitin7
0
Я не совсем понимаю что обозначает .IsEven и k+=1.Можно ли заменить эти строки чем-то другим?
Новые вопросы
Химия,
2 года назад
Литература,
2 года назад
Физика,
8 лет назад
Алгебра,
8 лет назад
Алгебра,
9 лет назад