Информатика, вопрос задал nikt08 , 6 лет назад

Напишите программу. Пользователь вводит число с клавиатуры, если это положительное число, то вывести это число в четвёртой степени (Например 5 в степени 4 = 625). Однако, если это число отрицательно, отнимите это этого числа 15.

Ответы на вопрос

Ответил nazikmuz
0

Відповідь:

#include <iostream>

#include <math.h>

using namespace std;

int main(){

setlocale(LC_ALL , "Rus");

float number;

cout << "Введите число: ";

cin >> number;

if(number >= 0){

 number = pow(number,4);

}

else{

 number -= 15;

}

cout << number << endl;

return 0;

}

Ответил drainer1
0

C# , Visual Studio (IDE) :

string InputData;

           TryAgain:

           Console.WriteLine("Введите число. "); InputData = Console.ReadLine();

           if( ! int.TryParse(InputData, out int Input))

           {

               Console.WriteLine("Некорректное значение, попробуйте ещё раз .");

               Console.ReadLine();

               goto TryAgain;

           }

           if (Input >= 0) Console.WriteLine($"Число в 4 степени: {Math.Pow(Input, 4)} .");

           else if (Input < 0) Console.WriteLine($"Число уменьшенное на 15: {Input - 15} .");

           Console.ReadLine();

Новые вопросы