Информатика, вопрос задал lerastepanebko , 8 лет назад

Напишите программу по заданной х и у, Определите принадлежит ли точка заштрихованной области

Приложения:

Ответы на вопрос

Ответил Filippzzz
0
Program Rick_and_Morty;
var x,y:integer;
Begin
write('введите x: ');
readln (x);
write('введите y: ');
readln (y);
if ((x>=0) and (y>=0) and (x*x+y*y<=25))
or ((x>=0) and (y>=0) and (x*x+y*y>=9))
or ((x>=0) and (y<=0) and (x*x+y*y<=25))
or ((x>=0) and (y<=0) and (x*x+y*y>=9))
then 
writeln('(',x,',',y,') - входят в облость')
else 
writeln('(',x,',',y,') - не входят в облость');

writeln('конец');
end.
Приложения:
Новые вопросы