Напишите программу перевода чисел из двоичной системы счисления в десятичную на паскале , используя простые формулы.
Ответы на вопрос
Ответил petyaGavrikov
0
var a:string[20]; st,b,i:integer;
begin
writeln('Введите двоичное число:');
readln(a);
st:=1; b:=0;
for i:=length(a) downto 1 do
begin
if a[i]='1' then b:=b+st;
st:=2*st;
end;
writeln(b);
end.
begin
writeln('Введите двоичное число:');
readln(a);
st:=1; b:=0;
for i:=length(a) downto 1 do
begin
if a[i]='1' then b:=b+st;
st:=2*st;
end;
writeln(b);
end.
Новые вопросы