Напишите программу, перемножающую целые числа без использования операции «*». Например, при умножении целых чисел n*m число m надо сложить само с собой n раз (m+m+…+m). На языке Паскаль.
Ответы на вопрос
Ответил mixonix
0
var m,n,i:integer;
begin
writeln('введите число ');
readln(n);
writeln('на что умножить? ');
readln(m);
for i:=1 to m-1 do n:=n+n;
writeln(n);
end.
begin
writeln('введите число ');
readln(n);
writeln('на что умножить? ');
readln(m);
for i:=1 to m-1 do n:=n+n;
writeln(n);
end.
Ответил mixonix
0
ошибся
Ответил mixonix
0
var m,n,i,n1:integer;
begin
writeln('введите число ');
readln(n);
n1:=n;
writeln('на что умножить? ');
readln(m);
for i:=1 to m-1 do n:=n+n1;
writeln(n);
end.
begin
writeln('введите число ');
readln(n);
n1:=n;
writeln('на что умножить? ');
readln(m);
for i:=1 to m-1 do n:=n+n1;
writeln(n);
end.
Новые вопросы