Напишите программу, печатающую количество максимальных элементов непустого массива. Язык С++
Ответы на вопрос
Ответил Guerrino
0
#include <iostream>
using namespace std;
int
main ()
{
int n, i, t = 1, m, a[100]; \ можно поставить свои ограничения;
cin >> n;
for (i = 0; i < n; i++)
cin >> a[i];
m = a[0] - 1;
for (i = 0; i < n; i++)
{
if (a[i] > m)
{
m = a[i];
t = 0;
};
if (a[i] == m)
t++;
};
cout << t;
return 0;
}
Новые вопросы
Українська література,
2 года назад
Русский язык,
2 года назад
Алгебра,
7 лет назад
Алгебра,
7 лет назад
Биология,
9 лет назад
География,
9 лет назад