НАПИШИТЕ ПРОГРАММУ ПАСКАЛЬ ПОЖАЛУЙСТА СРОЧНО!!!!!
В последовательности целых чисел найдите минимальное число и количество его повторений
Ответы на вопрос
Ответил Аноним
0
Var
Ch, n, Min, kMin: integer;
Begin
Write('Введите кол-во чисел последовательности: ');
ReadLn(n);
Min := 0;
kMin := 0;
WriteLn('Введите целые числа в кол-ве ', n, ' штук:');
For n := 1 to n do
Begin
Read(Ch);
if (Ch < Min) or (kMin = 0) then
Begin
Min := Ch;
kMin := 1;
End
else if (Ch = Min) then
kMin := kMin + 1;
End;
WriteLn('Минимальное число: ', Min);
WriteLn('Кол-во минимальный чисел: ', kMin);
End.
Новые вопросы