Информатика, вопрос задал TanyaRoshe , 2 года назад

Напишите программу Pascal в ЦИКЛИЧЕСКОМ алгоритме.
Задача:Определить,являются ли подобными 2 треугольника,если известны длины всех 3-х сторон каждого треугольника.

Ответы на вопрос

Ответил alamar
0
var a:array[1..2,1..3] of integer;
i,i1,i2,k:integer;
z:real;
begin
writeln('Vvedite storoni treugolnikov');
for i1:=1 to 2 do
for i2:=1 to 3 do
read(a[i1,i2]);
for i1:=1 to 3 do
for i2:=1 to 3 do
begin
if  a[1,i1]>a[1,i2] then
begin
k:=a[1,i2];
a[1,i2]:=a[1,i1];
a[1,i1]:=k;
end;
if  a[2,i1]>a[2,i2] then
begin
k:=a[2,i2];
a[2,i2]:=a[2,i1];
a[2,i1]:=k;
end;
end;
z:=a[1,1]/a[2,1];
for i2:=1 to 3 do
if a[1,i2]/a[2,i2]=z then i:=i+1;
if i=3 then writeln('da') else writeln('net');
end.
Новые вопросы