Напишите программу PASCAL с массивом, которая будет вводить массив РАНДОМНЫХ 10 чисел и сортировать их "методом пузырька"
Очень надо прошу, если не лень, то с комментариями! Даю максимум!
Ответы на вопрос
Ответ:
program z;//заголовок программы
const n=10;//количество элементов в массиве (заданное через постоянное значение)
var i,j,v:integer;//описание переменных для счётчиков и обмена значениями элементов
a:array [1..n]of integer;//описание переменной массива
begin//начало программного блока
write (' Исходный массив: ');//вывод строки для красоты и понятности
for i:=1 to n do//цикл со счётчиком
begin//начало составного оператора
a[i]:=random(90)+10;//присваивание значения элементам массива
write(a[i]:4);//вывод элементов массива на экран до сортировки
end;//конец составного оператора
writeln;//переход на новую строку для красоты и понятности
for i:=1 to n-1 do//начало сортировки с использование циклов
for j:=1 to n-1 do
if a[j] > a[j+1] then//сравнение значений двух элементов массива (неполное ветвление)
begin//начало составного оператора
v:=a[j];//начало обмена значений переменных
a[j]:=a[j+1];
a[j+1]:=v
end;//конец составного оператора
write ('Преобразованный массив: ');//вывод строки для красоты и понятности
for i:=1 to n do write(a[i]:4);//вывод элементов массива на экран после сортировки
end.//конец программного блока