напишите программу нахождения всех четных чисел,кратных P,
в диапазоне от N до М)пожалуйста ребята
Ответы на вопрос
Ответил simbion0
0
var
n,m,p,i:integer;
begin
write('Введите N,M,P через пробел: ');
readln(n,m,p);
For i:=n to m do
if (i mod p = 0) and (i mod 2 =0) then write(i,' ');
end.
n,m,p,i:integer;
begin
write('Введите N,M,P через пробел: ');
readln(n,m,p);
For i:=n to m do
if (i mod p = 0) and (i mod 2 =0) then write(i,' ');
end.
Ответил serd2011
0
Вот держи, я даже оформил красиво!
Var n,m,p,x,i:integer;
Begin
Write('Введите N >>> ');
Readln(n);
Write('Введите M >>> ');
Readln(m);
Write('Введите P >>> ');
Readln(p);
Writeln('------------------------------------------');
X:=0;
For i:=n to m do
If (i mod 2 = 0) and (i mod p = 0) and (i <> 0) then
Begin
X:=x+1;
Writeln(i,' - Чётное и кратно ',p);
End;
End.
Новые вопросы
Биология,
9 лет назад
Математика,
9 лет назад