Напишите программу нахождения произведения цифр 5ти значного числа на языке Паскаль. Заранее спасибо)
Ответы на вопрос
Ответил artark
0
program qqq;
var n, s, x1, z1, i, del: integer;
begin
writeln ('vvedi 5-znachnoe chislo < 32768');
{ограничение типа integer}
readln (n);
del:=10000;
for i:=1 to 5 do
begin
z1:= n mod del;
x1:= n div del;
s:=s+x1;
n:=z1;
del:=del div 10;
end;
writeln ('summa cifr=', s);
readln;
end.
var n, s, x1, z1, i, del: integer;
begin
writeln ('vvedi 5-znachnoe chislo < 32768');
{ограничение типа integer}
readln (n);
del:=10000;
for i:=1 to 5 do
begin
z1:= n mod del;
x1:= n div del;
s:=s+x1;
n:=z1;
del:=del div 10;
end;
writeln ('summa cifr=', s);
readln;
end.
Ответил artark
0
Извиняюсь. Невнимательно прочитал задание. После del:=10000; нужно добавить строку s:=1; строку s:=s+x1; заменить на s:=s*x1 строку writeln ('summa... поменять на writeln ('proizvedenie...;
Новые вопросы
Физика,
2 года назад
Математика,
2 года назад
Математика,
9 лет назад
Математика,
9 лет назад
Алгебра,
9 лет назад