Напишите программу нахождения длин медиан m1,m2 и m3, треугольника по указанными формулами . Длина сторон a,b,c задается с клавиатуры m1=1/2*sqrt(2a^2+2b^2-c^2); m2=1/2*sqrt(2a^2+2c^2-b^2); m3=1/4*sqrt(2b^2+2c^2-a^2);.
Ответы на вопрос
Pascal ABC(проверьте правильность написанных вами формул...)
uses crt;
var a,b,c,m1,m2,m3 : integer;
begin
writeln('Введите длины сторон треугольника a b c');
read(a,b,c);
m1:=1/2*sqrt(2*a^2+2*b^2-c^2);
m2:=1/2*sqrt(2(a^2+2*c^2-b^2);
m3:=1/4*sqrt(2*b^2+2*c^2-a^2);
writeln('m1= ',m1,'m2= ',m2,'m3= ',m3);
end.
var
a, b, c: real;
function mediana(a, b, c: real): real;
begin
mediana := 1 / 2 * sqrt(2 * a * a + 2 * b * b - c * c);
end;
begin
writeln('Введите длины сторон треугольника a b c');
read(a, b, c);
writeln('m1 = ', mediana(a, b, c));
writeln('m2 = ', mediana(a, c, b));
writeln('m3 = ', mediana(b, c, a));
end.