Информатика, вопрос задал strokovadasha , 7 лет назад

Напишите программу нахождение третьего по величине элемента массива.

Ответы на вопрос

Ответил Helper211
0

Ответ:

program Pascal;

const n=10;

Var i,max,max2,max3: Integer;

m: array[1..10] of integer;

Begin

m[1]:=random(10);

max:=m[1];

max2:=m[1];

max3:=m[1];

For i:=2 to n do  

begin

m[i]:=random(100);

write(m[i]:4);

end;

For i:=1 to n do  

begin

if (m[i]>max) then  

begin

max3:=max2;

max2:=max;

max:=m[i];

end

else if (m[i]>max2) then  

begin

max3:=max2;

max2:=m[i];

end

else if (m[i]>max3) then  

begin

max3:=m[i];

end;

end;

writeln();

writeln(max3);

End.

Ответил strokovadasha
0
спасибо большое
Новые вопросы