Информатика, вопрос задал kamilianova09 , 10 лет назад

Напишите программу находящую максимальное из четырех чисел (используйте процедуру для поиска максимального из двух чисел) 

Ответы на вопрос

Ответил Алиса104
0
program ufhg;
uses crt;
var a,b,c,d, m: integer;
begin 
readln(a,b,c,d);
m:=a;
if(b>m) then m:=b;
if(c>m) then m:=c;
if(d>m) then m:=d;
writeln(m);
end.
Ответил archery
0
а процедура где?
Ответил archery
0
var
    a, b, c, d: integer;

function max(i1, i2: integer): integer;
begin
    if i1 > i2 then max := i1 else max := i2;
end;

begin
    read(a, b, c, d);
    writeln(max(max(max(a, b), c), d));
end.

не помню как процедуры писать, но с функциями даже удобнее

Новые вопросы