Информатика, вопрос задал AZ75 , 7 лет назад

Напишите программу на языке программирования C++, которая в последовательности натуральных чисел определяет сумму чисел, кратных 5. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 5. Количество чисел не превышает 100. Введённые числа не превышают 300. Программа должна вывести одно число — сумму чисел, кратных 5. Пример работы программы: Входные данные: 3, 15, 25, 6. Выходные данные: 40.

Ответы на вопрос

Ответил leonidkorolev2007
0

Ответ:

#include <iostream>

#include <vector>

using namespace std;

int main() {

int n,sum=0;

cin >> n;//кол. числе в последовательности

vector<int> m(n);//создаем вектор с кол. элементов n

for (auto& v : m) {

 cin >> v;//заполняем элементы числами

 if (v % 5 == 0) sum += v;//прибавим к сумме если кратно 5

}

cout << endl << sum;//вывод суммы

}

Объяснение:

Новые вопросы