Информатика, вопрос задал dimanzare , 9 лет назад

Напишите программу на языке Паскаль, распознающую по длинам сторон среди всех треугольников прямоугольный. Если они прямоугольные, то должно выводится сообщение 'Это прямоугольный треугольник'.

Ответы на вопрос

Ответил Астрa
0
var a,b,c:real;
begin
read(a, b, c);
if ((a=sqrt(sqr(b)+sqr(c)))or(b=sqrt(sqr(a)+sqr(c)))or(c=sqrt(sqr(a)+sqr(b))))then
write('Это прямоугольный треугольник')
else
write('Это не прямоугольный треугольник')
end.
Ответил dimanzare
0
c = √(a^2 + b^2)
Ответил Астрa
0
но совершенно не обязательно вводить их в таком прядке
Ответил dimanzare
0
огромное спасибо еще раз
Новые вопросы