Информатика, вопрос задал rraazz710 , 2 года назад

Напишите программу на языке паскаль , которая будет делииь пирог на равные части по весу. ( масса пирога/кол во учеников ) Если кол во учеников = 0 , то должно выйти сообщение " 0 учеников в классе не может быть "

Ответы на вопрос

Ответил mirageKZ
1

Ответ:

var

 m, d :integer;

 part : double;

begin

 writeln('Масса пирога =');

 readln(m);

 writeln('количество учеников =');

 readln(d);

 if d > 0 then begin

   part := m/d;

   writeln('Вес каждой части пирога = ', part:2:2)

 end

 else

   writeln('0 учеников в классе не может быть');

end.

Новые вопросы