Информатика, вопрос задал polinastarikova25 , 6 лет назад

Напишите программу на языке Паскаль и постройте блок-схему алгоритма для решения задачи по алгебре. Дана арифметическая прогрессия. Известны 1-й член последовательности и разность. Найдите 20-й член этай прогрессии и сумму первых 30 её членов​


Аноним: я из интернет урока, могу добавить в группу с ответами ( писать в тг @kiruminiko)

Ответы на вопрос

Ответил vimmortal2
21

Программа:

Pascal:

var a1, d, a20, S30: real;

begin

 write('a1 = ');  readln(a1);

 write('d = ');  readln(d);

 

 a20 := a1 + 19 * d;

 writeln('a20 = ', a20);

 

 S30 := 30 * (2*a1 + 29*d) / 2;

 writeln('S30 = ', S30);

end.

Объяснение:

В начале регистрируются 4 переменных, необходимых по условию: a1, d, a20, S30 - у них будет вещественный тип данных. Далее вводятся a1, d с клавиатуры, для будущих вычислений. По формуле: a_{n} = a_{1} + d(n-1) находим 20-й член прогрессии, а по формуле S_{n} = \dfrac{2a_{1}+d(n-1)}{2} *n находим сумму 30-ти первых членов прогрессии. После вычисления идёт вывод, но небольшой интервал будет не так заметен для человеческого глаза.

Блок-схема прикреплена.

Результат:

a1 = 10

d = 5

a20 = 105

S30 = 2475

a1 = 50

d = 10

a20 = 240

S30 = 5850

Приложения:
Новые вопросы