Информатика, вопрос задал Mysterycocks , 9 лет назад

Напишите программу на языке Pascal, которая с помощью цикла for to считала s:=1-2+3-4+5-6+7-8+9-10....

Ответы на вопрос

Ответил petyaGavrikov
0
var n,i,s:integer;
begin
write('n = '); readln(n);
s:=0;
for i:=1 to n do 
 if i mod 2 =0 then s:=s-i else s:=s+i;
writeln('s = ',s);
end.

Пример:
n = 10
s = -5
Ответил vladmor
0
var n,s,i:integer;
begin
  write('введите n ');
  readln(n);
  for i:=1 to n do if i mod 2 <> 0 then s:=s+i else s:=s-i;
  writeln('s = ',s);
end.
Ответил vladmor
0
И у меня при n=10 получилось -5 )))
Ответил petyaGavrikov
0
Видимо, мы написали правильную программу )))
Новые вопросы