Напишите программу на языке Pascal.Элементы массива А, удовлетворяющие условию А(i)>5.5, переписать в массив В, а элементы, удовлетворяющие условию А(i)<=5.5, переписать в массив С. В массиве А m элементов.
Ответы на вопрос
Ответил PatifonKakao
0
var
A,B,C: array[1..100] of integer;
i,n,j,k:integer;
begin
randomize;
j:=0;
k:=0;
Readln(n);
Writeln('Исходный массив:');
for i:=1 to n do
begin
A[i]:=random(10);
writeln('A[',i,']=',A[i]);
end;
for i:=1 to n do
if A[i]>5.5
then
begin
j:=j+1;
B[j]:=A[i];
end;
for i:=1 to n do
if A[i]<=5.5
then
begin
K:=k+1;
C[k]:=A[i];
end;
for i:=1 to j do
writeln('B[',i,']=', B[i]);
for i:=1 to k do
writeln('C[',i,']=', C[i]);
end.
A,B,C: array[1..100] of integer;
i,n,j,k:integer;
begin
randomize;
j:=0;
k:=0;
Readln(n);
Writeln('Исходный массив:');
for i:=1 to n do
begin
A[i]:=random(10);
writeln('A[',i,']=',A[i]);
end;
for i:=1 to n do
if A[i]>5.5
then
begin
j:=j+1;
B[j]:=A[i];
end;
for i:=1 to n do
if A[i]<=5.5
then
begin
K:=k+1;
C[k]:=A[i];
end;
for i:=1 to j do
writeln('B[',i,']=', B[i]);
for i:=1 to k do
writeln('C[',i,']=', C[i]);
end.
Новые вопросы
Қазақ тiлi,
2 года назад
Русский язык,
2 года назад
Химия,
9 лет назад
Физика,
10 лет назад
Математика,
10 лет назад