Информатика, вопрос задал marusia478 , 1 год назад

Напишите программу на языке Pascal: Даны два числа, не равные друг другу. Меньшее из ниг заменить половиной их суммы, я большее - удвоенным произведением. Помогите, пожалуйста

Ответы на вопрос

Ответил Fchchchv
3

Ответ:

удвоенным произведением я понял как 2*(2*3)
если по другому напиши исправлю

Объяснение:

program ReplaceNumbers;

var

 a, b,smaller2, smaller, bigger: real;

begin

 writeln('Enter two numbers (not equal):');

 readln(a, b);

 

 if a < b then

 begin

   smaller := a;

   bigger := b;

 end

 else

 begin

   smaller := b;

   bigger := a;

 end;

 

 smaller2 := (smaller + bigger) / 2;

 bigger := 2 * smaller * bigger;

 

 writeln('The new values are:');

 writeln(smaller2:0:2);

 writeln(bigger:0:2);

 

 readln;

end.

Приложения:
Новые вопросы