Напишите программу на с++, которая в последовательности натуральных чисел определяет минимальное чётное число. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется чётное число. Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число — минимальное чётное число.
Ответы на вопрос
Ответил HQLogRider
0
Ответ:
#include <iostream>
using namespace std;
int main(){
int n;
cin >> n;
int ans = 30001;
for (int i = 0; i < n; ++i){
int now_number;
cin >> now_number;
if (now_number % 2 == 0) ans = min(ans, now_number);
}
cout << ans;
}
Новые вопросы
Английский язык,
2 года назад
Английский язык,
2 года назад
Математика,
6 лет назад
Математика,
6 лет назад
Математика,
8 лет назад
География,
8 лет назад