Информатика, вопрос задал ketrinkryt , 2 года назад

Напишите программу на С++
Известна зарплата каждого из 12 работников фирмы за каждый месяц первого квартала (3 месяца) определите
А. Общую сумму выплаченую Всем работникам
Б. Зарплату полученую каждым работником за квартал
В. Общую зарплату всех работников за каждый месяц

Ответы на вопрос

Ответил BobbyFresnel
5

===== C++ 17 =====

#include <iostream>

using namespace std;

int main()

{

   srand(time(NULL));

   int n = 12, k = 3;

   int a[k][n];

   for(int i = 0; i < k; i++)

   {

       for(int j = 0; j < n; j++)

       {

           a[i][j] = (rand() % 35 + 25) * 1000;

           cout << a[i][j] << " ";

       }

       cout << endl;

   }

   cout << "\nОбщая сумма, выплаченная всем работникам: ";

   int s = 0;

   for(int i = 0; i < k; i++)

       for(int j = 0; j < n; j++)

           s += a[i][j];

   cout << s << "\nЗарплаты каждого работника за квартал:\n";

   s = 0;

   for(int j = 0; j < n; j++)

   {

       s = 0;

       for(int i = 0; i < k; i++)

       {

           s += a[i][j];

       }

       cout << s << " ";

   }

   cout << "\nОбщие зарплаты всех работников по месяцам: ";

   for(int i = 0; i < k; i++)

   {

       s = 0;

       for(int j = 0; j < n; j++)

       {

           s += a[i][j];

       }

       cout << s << " ";

   }

   cout << endl;

   return 0;

}

Приложения:
Новые вопросы