Информатика, вопрос задал antonsoloviev2016 , 2 года назад

Напишите программу на Python.
"Найти количество четных цифр заданного натурального числа N."

Ответы на вопрос

Ответил pinguinbird
1

while True:

 try:

   n = int(input('Введите натуральное число: '))

   break

 except ValueError:

   print('Неверные входные данные. Попробуйте снова.')

n = abs(n)

b = 0

while n>0:

 if n%10%2 == 0:

   b+=1

 n = n//10

print('Количество чётных цифр в ведённом числе равно ' + str(b))

Новые вопросы