Информатика, вопрос задал remushevmarat2007 , 7 лет назад

Напишите программу на Python
Найди самого большого.

Пользователь вводит последовательность целых чисел (каждое число на новой строке). Если пользователь вводит 0, то последовательность заканчивается.
Напишите программу, которая будет считать индекс (порядковый номер) самого большого числа.

Подсказка: первое введенное число сначала является самым большим. Потом ситуация может поменяться. Мы принимаем новые числа ПОКА новое число не равно нулю.

Ответы на вопрос

Ответил Аноним
0

number_list = []

number = 1

while number != '0':

   number = str(input())

   number_list.append(int(number))

   if number == 0:

       number_list.remove(number)

       break

maximum_element = max(number_list)

print('индекс самого большого элемента: ' + str(number_list.index(maximum_element)))

print('самый большой элемент: ' + str(maximum_element))

Новые вопросы