Информатика, вопрос задал Alica3Kit , 2 года назад

Напишите программу на Python, которая выводит таблицу значений функции y = | х |. Диапазон
изменения аргумента от –2 до 2, шаг увеличения аргумента 0,5.​

Приложения:

Ответы на вопрос

Ответил valgrisa
15

Ответ:

print('{:^7}{:^7}'.format('x','y'))

print('-'*13)

x=-2

while x<=2:

   print(f'{x:5.1f}{abs(x):7.1f}')

   x+=0.5

Объяснение:

скрин

используем цикл с предусловием (while x<=2:)

abs (х) - возвращает абсолютное значение (модуль) x

format - строковый метод вставляет переданные в него данные в строку, к которой применяется. Места вставки обозначаются фигурными скобками. Метод format позволяет задавать ширину поля и выравнивание

f - перед f-строками (форматированные строковые литералы) ставится буква f, в строке могут находиться включения в фигурных скобках, позволяет задавать ширину поля и количество знаков после запятой

Приложения:

nargizanarmetova68: ну верно да
Ответил Mikail2006
13

x = float(-2)

print(f'  x     y\n-----------')

while x != 2.5:

   y = x

   if abs(x) == x:

       y = ' ' + str(x)

   print(f"{y}   {abs(x)}")

   x = x + 0.5

Приложения:

Mikail2006: Thonny
molodesim: а чооо пон
meowzxh: ог
timakostylev840: ичо пон
nika0873: Это за какой класс?
timakostylev840: ну бош ичо пон
Новые вопросы