Информатика, вопрос задал ewist6603 , 7 лет назад

Напишите программу на python, которая вычисляет средний рост учеников. Алгоритм должен в цикле просить пользователя ввести рост ученика. Цикл завершается, когда пользователь введет рост, равный нулю. Программа должна вывести средний рост учеников в классе.

Формат ввода
Вводятся целые числа одно за другим, на отдельных строках.

Формат вывода
Выводтся одно значение среднего роста

Ответы на вопрос

Ответил regmay
0

n=0

s=0

a=1

while a!=0:

   a=int(input())

   n+=1

   s+=a

print(s/(n-1))

Новые вопросы