Информатика, вопрос задал vit270906 , 2 года назад

Напишите программу на питон срочно!!! Даю 30 баллов!!!
Напишите программу, которая оценит справедливость конспирологического тарифа. Из списка чисел нужно выбрать те, что имеют ту же чётность, что и минимальное.

Формат ввода
Вводится строка целых чисел, записанных через пробел.

Формат вывода
Вывести числа, которые имеют ту же чётность, что и наименьшее, без повторений, порядок вывода неважен.

Пример 1
Ввод
2 5 17 3 18 6 1 9
Вывод
1 3 5 9 17


RussianWanderer: Сейчас напишу
vit270906: Можешь пожалуйста потом на мои 2 вопроса ещё ответить пожалуйста. Там тоже нужно написать программу. Буду очень благодарен.

Ответы на вопрос

Ответил RussianWanderer
3

a = list(map(int, input().split()))

m = min(a)

res = []

for i in range(len(a)):

   if(a[i]%2==m%2 and a[i] not in res):

       res.append(a[i])

for row in range(len(res)):

   print(res[row], end=' ')


vit270906: Спасибо!!!
vit270906: Сможешь мне помочь ещё с двумя программами??? Я там за задачи дал по 20 баллов
RussianWanderer: Да, сейчас
vit270906: Программа выводит только цифру: Пример 1
Ввод
2
V A L U E S I N T H E C H A I R
I N M A R X I S T T E R M S
S K Y T O B I R D S
T U R N T O T H E C H A I R S
Вывод
L U M X H V C
U N E K D A H Y B C
vit270906: А всё
Это я не то посмотрел
vit270906: Привет, ты сможешь мне помочь с написанием программ 25 декабря? Я выложу их примерно 16:30 -17:00. Если не сложно. Я буду очень благодарен тебе.
RussianWanderer: Я 25 буду занят в это время, прости
RussianWanderer: Кстати, а можешь эти ответы отметить как лучшие пожалуйста)
vit270906: Обмдно(((
vit270906: Отметил)))
Новые вопросы