Информатика, вопрос задал calvin99 , 7 лет назад

напишите программу на Паскале: Три точки заданы своими координатами на плоскости, определить минимальный радиус окружности охватывающий все эти точки ( центр в начале координат, минимальный радиус считается по самой удолённой точке, соответственно окружность должна лежать на нёй)

Ответы на вопрос

Ответил nubpolymaster
0

uses math;

var x1, x2, x3, y1, y2, y3: real;

begin

read(x1, y1, x2, y2, x3, y3);

writeln(max(max(sqrt(x1 * x1 + y1 * y1), sqrt(x2 * x2 + y2 * y2)), sqrt(x3 * x3 + y3 * y3)));

end.

Новые вопросы