Информатика, вопрос задал kirillhworkk , 1 год назад

Напишите программу на паскале
Сформировать массив десяти случайных целых чисел, диапазона заданного пользователем. Выполнить сортивку четных чисел по возрастанию

Ответы на вопрос

Ответил enxt
0

program RandomArray;

const

 N = 10;  // размер массива

var

 a: array[1..N] of integer;  // массив целых чисел

 i, min, temp: integer;  // переменные для цикла и сортировки

begin

 randomize;  // инициализируем генератор случайных чисел

 // считываем диапазон случайных чисел от пользователя

 writeln('Введите минимальное и максимальное значения диапазона:');

 readln(min, max);

 // заполняем массив случайными числами

 for i := 1 to N do

   a[i] := random(max - min + 1) + min;

 // сортируем четные числа по возрастанию

 for i := 1 to N - 1 do

   if (a[i] mod 2 = 0) then  // если число четное

     for j := i + 1 to N do

       if (a[j] mod 2 = 0) and (a[i] > a[j]) then  // если число четное и меньше чем a[i]

         begin

           temp := a[i];

           a[i] := a[j];

           a[j] := temp;

         end;

 // выводим отсортированный массив

 writeln('Отсортированный массив:');

 for i := 1 to N do

   write(a[i], ' ');

end.


kirillhworkk: Мне пишет что j нужно в переменную засунуть,чтобы прошла компиляция, что с ней делать?
enxt: хз, у меня запускается
Новые вопросы