Информатика, вопрос задал noobik446 , 7 лет назад

Напишите программу на Паскале по обработке одномерных массивов. Количество элементов в массиве задается самим пользователем, а сам массив генерируется из случайных чисел. Результаты вывести на экран.
В одномерном массиве, состоящем из n вещественных элементов, вычислить:
номер минимального элемента массива.

Ответы на вопрос

Ответил olegkofi56
0

Ответ:

program n1;

uses crt;

var aw:array[1..10] of integer;

i,w,g:integer;

begin

g:=0;

w:=10;

for i:=0+1 to w do begin

aw[i]:=random(100);

write(aw[i]:6);

end;

writeln();

write('Чот');

for i:=0+1 to w do begin

if aw[i] mod 2 = 0 then g:=g+1; end; write('Всего чотных чисел ',g);

writeln();

write('Не чот');

g:=0;

for i:=0+1 to w do begin

if aw[i] mod 2 > 0 then g:=g+1;end; write('Всего не чотных чисел ',g) ;

end.

uses crt;

const

n=10;

var

mas:array[1..n] of integer;

i,c,b:integer;

begin

randomize;

c:=0;

b:=0;

for i:=1 to n do

mas[i]:=random(101)+1;

for i:=1 to n do

write(mas[i],' ');

for i:=1 to n do

begin

if mas[i] mod 2=0 then

inc(c);

end;

writeln('c=',c);

for i:=1 to n do

begin

if mas[i] mod 2<>0 then

inc(b);

end;

writeln('b=',b);

end.

const n = 10;

type Mstring = array [1..n] of string;

var m:Mstring;

procedure InputM(var arg:Mstring);

var i:byte;

begin

for i:=1 to n do

begin

writeln('enter string number ',i);

readln(arg[i]);

end;

end;

procedure OutputM(const arg:Mstring);

var i:byte;

begin

for i:=1 to n do

begin

writeln(arg[i]);

end;

end;

function repl(const arg:string):string;

var i:byte;

res:string;

begin

res:=arg;

for i:=1 to length(res) do

begin

if res[i] = '!' then res[i]:='.';

end;

repl:=res;

end;

procedure MasRepl(var arg:Mstring);

var i:byte;

begin

for i:=1 to n do

begin

arg[i]:= repl(arg[i]);

end;

end;

begin

InputM(m);

MasRepl(m);

OutputM(m);

readln;

end.

Новые вопросы