Напишите программу на паскале, которая выбирает из списка футболистов лучшего бомбардира – того, кто забил наибольшее количество мячей. Если несколько человек забили одинаковое наибольшее количество мячей, нужно вывести их имена и фамилии в том порядке, в котором они встречаются в исходном списке.
Входные данные
В первой строке записано количество футболистов в списке N . Следующие N строк имеют формат:
<фамилия> <имя> <год рождения> <число забитых мячей>
Выходные данные
Программа должна вывести фамилии и имена тех футболистов, которые забили наибольшее количество мячей. В последней строке программа выводит количество голов, забитых каждым из этих футболистов.
Ответы на вопрос
Ответил Hdj1
0
var
n,i,j,max,k: Integer;
lname, name: array [1..100000] of String;
y,g,a:array [1..100000] of longint;
begin
Read(n);
for i:=1 to n do
begin
read(lname[i]);
read (name[i]);
read(y[i],g[i]);
if (max<g[i]) or (i=1) then
max:=g[i];
end;
for i:=1 to n do
if g[i]=max then
begin
writeln(lname[i], ' ', name[i]);
j:=j+1;
a[j]:=i;
end;
for i:=1 to j do
write(g[a[i]], ' ');
end.
Ответил HNLLZ
0
После ввода первой строки [с данными футболиста] программа вылетает и пишет runtime error 106
Новые вопросы
Русский язык,
2 года назад
Русский язык,
2 года назад
Математика,
7 лет назад
География,
7 лет назад
Алгебра,
9 лет назад