Напишите программу на Паскале, которая находит y=a/b, когда b равен 0 и b не равен 0
Ответы на вопрос
Ответил palatin34
0
program abc;var y,a,b:real;beginreadln(a,b);y:=a/b;if b=0 then writeln('Ошибка данных')else writeln(y);end.
Ответил palatin34
0
program abc;
var y,a,b:real;
begin
readln(a,b);
y:=a/b;
if b=0 then writeln('Ошибка данных')
else writeln(y);
end.
var y,a,b:real;
begin
readln(a,b);
y:=a/b;
if b=0 then writeln('Ошибка данных')
else writeln(y);
end.
Ответил palatin34
0
Немного подправил, чтоб глаза не резало)
Ответил petyaGavrikov
0
var a,b:real;
begin
readln(a,b);
if b=0 then writeln('Деление на 0')
else writeln('y = ',a/b);
end.
Пример:
5 2
y = 2.500000000000000e+00
begin
readln(a,b);
if b=0 then writeln('Деление на 0')
else writeln('y = ',a/b);
end.
Пример:
5 2
y = 2.500000000000000e+00
Новые вопросы