Информатика, вопрос задал kashak228336 , 2 года назад

Напишите программу (на паскале) для нахождения наибольшего общего делителя для чисел 12, 24, 30, 48 и 51 с использованием процедуры​


kashak228336: Нужно писать для 5 чисел вместе

Ответы на вопрос

Ответил CS3R
2

Ответ:

var a,b: integer;

function NOD(x,y: integer): integer;

begin;

  if x<>0 then NOD:=NOD(y mod x,x) else NOD:=y;

end;

begin;

  readln(a,b);

  writeln( 'НОД= ', NOD(a,b) );

end.

Объяснение:

begin(в переводе с английского начало)

if x<>0 then NOD:=NOD(y mod x,x) else NOD:=y(пишем этот код)

end(в переводе с английского конец)

Дальше пишем как я написал


kashak228336: а где тут в коде сами числа то?
kashak228336: просто я не написал
kashak228336: надо писать для 5ти чисел вместе
Новые вопросы