Информатика, вопрос задал korshundenchik , 7 лет назад

Напишите программу на паскале для двумерного массива

Приложения:

Ответы на вопрос

Ответил Puz1koO
1

const

 n=5; m=6;

var

 b:array [1..n,1..m] of integer;

 i,j,pol,pus:integer;

begin

 pus:=0; pol:=0;

 for i:=1 to n do

   begin

     for j:=1 to m do  

       begin

         b[i,j]:=random(21)-10;

         write(b[i,j]:4);

         if (b[i,j]>0) then

           inc(pol)

             else

               if b[i,j]=0 then

                 inc(pus);

       end;

     writeln;

   end;

 writeln('Положительных: ',pol);

 writeln('Отрицательных: ',n*m-pus-pol);

end.


korshundenchik: А откуда вы взяли n=5 и m=6
korshundenchik: Я просто не особо понимаю
Puz1koO: В условии указаны просто n и m без значений. Задал их сам. Можно поставить любое значение
Новые вопросы