Информатика, вопрос задал kekpolina , 9 лет назад

напишите программу на паскале

Дано трехзначное число. Определить кратна ли сумма его цифр числу а.

Пример работы программы:

Входные данные Выходные данные
633 No
4

540 Yes
2

Ответы на вопрос

Ответил Akelvud
0
var
 a,b,c,d,e:longint;
begin
 readln(a);
 readln(c);
 d:=d+a mod 10;
 d:=d+a div 10 mod 10;
 d:=d+a div 100 mod 10;
 if d mod c = 0 then writeln('Yes') else writeln('No');
end.

Ответил kekpolina
0
спасибо тебе,да хранит тебя бог
Ответил kekpolina
0
кек
Новые вопросы