Напишите программу на паскале
А.выясните какие числа ввел пользователь: положительное или отрицательное?
Б.выясните какие числа ввел пользователь: четное или нечетное ?
Ответы на вопрос
Ответил SanGreen74
0
var x:integer;
begin
writeln('Введите число');
readln(x);
if x>0 then write('Число положительное и ')
else write('Число отрицательное и ');
if x mod 2=0 then write('четное.')
else writeln('нечетное');
end.
begin
writeln('Введите число');
readln(x);
if x>0 then write('Число положительное и ')
else write('Число отрицательное и ');
if x mod 2=0 then write('четное.')
else writeln('нечетное');
end.
Ответил Gleb1Kosyrev
0
С каких пор 0 стал отрицательным числом?
Ответил Gleb1Kosyrev
0
//Pascal ABC.NET v3.1 сборка 1219
Var
n:integer;
begin
readln(n);
if n>0 then writeln('Положительное');
if n<0 then writeln('Отрицательное');
if n=0 then writeln('0');
if n mod 2=0 then writeln('Чётное') else writeln('Нечётное');
end.
Пример ввода:
1
Пример вывода:
Положительное
Нечётное
Var
n:integer;
begin
readln(n);
if n>0 then writeln('Положительное');
if n<0 then writeln('Отрицательное');
if n=0 then writeln('0');
if n mod 2=0 then writeln('Чётное') else writeln('Нечётное');
end.
Пример ввода:
1
Пример вывода:
Положительное
Нечётное
Новые вопросы
Математика,
2 года назад
Химия,
2 года назад