Информатика, вопрос задал nsvetlana96 , 10 лет назад

Напишите программу на паскаль. Дано число n меньше или равно 30 000. Изменяя число i от 1 до n будем записывать получившееся число подряд без пробелов, и получим некое число. Подсчитать в этом числе количество нулей, единиц, двоек до девяток. Подсчитать общее количество цифр в этом числе. 

Ответы на вопрос

Ответил Bakalavr
0
program test;
var i,n,schet:integer;s:string;
begin
readln(n);
for i:=1 to n do
s:=s+inttostr(n);
schet:=length(s);
writeln(schet);
end.
Ответил nsvetlana96
0
спасибо вам большое, вы меня спасли
Новые вопросы