Информатика, вопрос задал keidjekk898 , 2 года назад

Напишите программу. Массив состоит из 5 элементов. Его необходимо заполнить рандомными числами от -40 до 40. Найти сумму четных индексов массива (номера четных домиков). Вывести эти элементы и сумму.

Ответы на вопрос

Ответил itsgest
2

import random

num = []

result = 0

for i in range(5):  #Заполняем список рандомными числами

   value = random.randint(-40, 40)

   num.append(value)

for i in num:   #Находим сумму четных цифр

   if i % 2 == 0:

       result += i

print(num)

print(result)

Новые вопросы