Информатика, вопрос задал wolfw3720 , 6 лет назад

Напишите программу, которой вводятся три числа (длина и ширина прямоугольника и длина произвольного отрезка).Выведите "Да", если отрезок можно разместить целиком внутри прямоугольника, иначе выведите "Нет"
P.s язык любой


DanyaVaryanitsa: За 8 балів навіть заморачуватися не буду!!!

Ответы на вопрос

Ответил benisXD
1

на питоне

from math import *

def wolfw():

   x,y,z=int(input()),int(input()),int(input())

   diagonal=sqrt(x**2+y**2)

   if z<=diagonal:print('да')

   else:print('нет')

wolfw()


DanyaVaryanitsa: Я хоч і не знавець, але print() пишеться через ентер.
benisXD: совершенно не обязательно
DanyaVaryanitsa: Аааа. Тоді добре. Спасибі!! Незнав.
Ответил vimmortal2
0

Программа:
Python:

n1, n2, n3 = map(int, input().split())

hypotenuse = (n1**2 + n2**2)**(1/2)

if n3 > hypotenuse:  print('Нет')

else:  print('Да')

Объяснение:

В начале вводятся три числа, необходимые по условию (в одну строку, через пробел). Далее вычисляем значение диагонали этого треугольника (это - гипотенуза двух образованных треугольников при проведении гипотенузы). Этот отрезок можно разместить целиком внутри прямоугольника, когда он меньше либо равен диагонали (гипотенузе). По условию выводим соответствующий текст.

Новые вопросы