Напишите программу, которая запрашивает пятиразрядное число и выводит число, составленное из цифр данного числа взятых задом наперёд.
Sample Input 1:12345
Sample Output 1:54321
Sample Input 2:12000
Sample Output 2:21
БЕЗ ИСПОЛЬЗОВАНИЯ IF И WHILE'
Это С++ ес что
Ответы на вопрос
Ответил MrMiner1
1
#include <iostream>
using namespace std;
int main() {
int n, arr[5];
cin>>n;
arr[0]=n/10000; arr[1]=n%10000/1000;
arr[2]=n%1000/100;arr[3]=n%100/10;
arr[4]=n%10;
n=10000*arr[4]+1000*arr[3]+100*arr[2]+10*arr[1]+arr[0];
cout<<n;
return 0;
}
Новые вопросы