Информатика, вопрос задал s4ndstrm , 2 года назад

Напишите программу, которая запрашивает дробные числа (double Программа должна остановиться запрашивать, когда мы вводим 0. Программа должна вывести умножение всех введенных чисел.
Ввод

3.1 2.4 1.2 0
вывод
8,928
 с++


gamemasterpro958: привет помоги мне пожалуста сижу питаюсь решить но не могу задание в профиле

Ответы на вопрос

Ответил nikkonwork
1

Відповідь:

#include <iostream>

using namespace std;

int main()

{

   double ans, res = 1;

   while (ans != 0){

       cin >> ans;

       if (ans != 0) res *= ans;

   }

   cout << "Output: " << res;

}

Пояснення:


nikkonwork: можно условие (ans != 0) в обоих местах заменить на просто (ans), поскольку если ans станет 0 проверку такое условие тоже не пройдет, тк 0 это False. Но это уже как кому понятнее будет
brawltop71008: Привет, s4ndstrm если ты разбираешься в Истории Украине не мог бы мне помочь с задание которое я опубликовал?
Новые вопросы