Информатика, вопрос задал mkambaraliev , 2 года назад

Напишите программу, которая запрашивает числа. Программа должна остановиться запрашивать, когда мы вводим 0.


Программа должна вывести количество введенных чисел и среднее значение. питон
Ввод:

3 8 9 0

Вывод:

3

6.67


03090d: Можно побольше баллов?
mkambaraliev: 10 норм
03090d: 30
mkambaraliev: хаха
mkambaraliev: 5 пойдет?

Ответы на вопрос

Ответил daraprelj
0

N = int(input())

s = 0

k = 0

sr = 0

while N != 0:

   s += N

   k += 1

   N = int(input())

sr = s/k

print('Количество введённых чисел - ',k)

print('Среднее арифметическое введённых чисел = ',sr)

Приложения:

mkambaraliev: не совсем понятно
daraprelj: Я дала решение. Объяснений в задании не требовалось, так что разбирайтесь сами
mkambaraliev: скопировать я тоже могу. надо решить более доступно
Ответил KnowsUser1
0

Ответ:

//Python 3.8.3

from typing import Callable, Any, Iterable

import statistics

def ReadSeqIntWhile(predicate: Callable[[Any], bool]) -> Iterable[Any]:

   temp = int(input())

   while(predicate(temp)):

       yield temp  

       temp = int(input())

def main():

   sequence = list(ReadSeqIntWhile(lambda p: p != 0))

   print(f"numbers count: {len(sequence)}, average value: {statistics.mean(sequence)}")

if __name__ == "__main__":

   main()

Новые вопросы