Информатика, вопрос задал troczkii19 , 7 лет назад

Напишите программу, которая заполняет список из 20 элементов случайными целыми числами на отрезке [50; 150]​

Приложения:

lozromanik: язык какой?
troczkii19: python

Ответы на вопрос

Ответил Рулез
1

Ответ:

На Python:

from random import randint

a = []

summ_of_ends35 = 0

count_of_even = 0

count_of_tens_even = 0

summ_of_squares_even = 0

max1 = 0

max2 = 0

for _ in range(20):

   num = randint(50, 150)

   if str(num).endswith('3') or str(num).endswith('5'):

       summ_of_ends35 += num

   if num % 2 == 0:

       count_of_even +=1

       summ_of_squares_even += num**2

   if int(str(num)[-2]) % 2 == 0:

       count_of_tens_even +=1

   if num > max1:

       max1 = num

   if max2 < num != max1:

       max2 = num

   a.append(num)

print('Массив:{0}\nСумма елемнтов оканчивающихся на 3 или 5: {1}\nКоличество чётных элементов: {2}\nКоличество '

     'элементов в которых число десятков чётное: {3}\nДва максимальных элемента: {4}, {5}\nСумма квадратов всех чётных'

     ' элементов: {6}'.format(a, summ_of_ends35, count_of_even, count_of_tens_even, max1, max2, summ_of_squares_even))

Объяснение:

Новые вопросы