Информатика, вопрос задал ввпутин18 , 8 лет назад

напишите программу, которая заполняет матрицу размером 7
продолжение внизу
прогу только для рисунка по середине

Ответы на вопрос

Ответил KolyaChep12
0
Const   N = 7;Var   A:array[1..N,1..N] of integer;   i,j:integer;BeginFor i:= 1 to N do    Begin    For j:= 1 to N do        Begin        A[i,j]:=random(21)-10;        Write(A[i,j]:3,' ')        End;    WriteLn    End;WriteLn;For i:= 1 to N div 2+(N mod 2) do    Begin    For j:= 1 to N do        Begin        if (j<=N div 2+i)and(N div 2-i+(N mod 2)<j) then A[i,j]:=99;        Write(A[i,j]:3,' ')        End;    WriteLn;    End;For i:= (N div 2)+(N mod 2)+1 to N do    Begin    For j:= 1 to N do        Begin        if (i-N div 2-1<j)and(j<=N+N div 2+1-i) then A[i,j]:=99;        Write(A[i,j]:3,' ')        End;    WriteLn;    End;End.
Ответил KolyaChep12
0
упс... Что то тут не так
Новые вопросы